[Sev2] Watchlist Transaction Screening - Service Degradation

Incident Report for Socure

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 19:32 EST

Monitoring

Our team has implemented a fix to mitigate the errors seen from our watchlist product. Our technical team is monitoring the issue and will continue sharing updates.
Posted Jan 09, 2026 - 18:37 EST

Update

We are continuing to investigate this issue.
Posted Jan 09, 2026 - 18:13 EST

Investigating

We are experiencing elevated error rate on our watchlist product for transactions screening adverse media. Our technical team is investigating the issue and will provide an update as soon as possible.
Posted Jan 09, 2026 - 18:11 EST
This incident affected: Global Watchlist (Global Watchlist Screening with Monitoring, Watchlist Standard, Watchlist Plus, Watchlist Premier).