SSA Early System Shutdown Announcement

Scheduled for May 16, 21:00 EDT  -  May 17, 08:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 27, 2026 - 09:44 EDT

Scheduled

Please be advised that SSA online systems will shut down two hours early, at 9:00 PM ET instead of 11:00 PM ET, on May 16th, 2026.

All systems are expected to be available again by 8:00 AM ET on Sunday, May 16th, 2026, for the start of business.

eCBSV will remain operational per normal schedules.
Posted Apr 27, 2026 - 09:44 EDT
This scheduled maintenance affects: Socure ID+ Platform (eCBSV) and RiskOS Platform (eCBSV).