[SEV3] Increased Latency In International Phone Risk Score

Incident Report for Socure

Resolved

This issue has been resolved as of 12:19 PM EDT.
Posted Mar 12, 2026 - 12:37 EDT

Update

We are continuing to investigate this issue.
Posted Mar 12, 2026 - 12:36 EDT

Investigating

We are investigating an increase in latency in the International Phone Risk Score module.
Posted Mar 12, 2026 - 12:15 EDT
This incident affected: Socure ID+ Platform (International Phone RiskScore).