eCBSV Transaction Failure due to high latency

Incident Report for Socure

Resolved

SSA resolved the elevated latency affecting the eCBSV module as of 2:00 AM ET. Response times have returned to normal. Thank you for your patience and understanding.
Posted Sep 03, 2026 - 11:18 EDT

Identified

Our Vendor, SSA, has reported that there is currently an elevated latency issue affecting eCBSV module. As a result, you may experience elevated response times. Our team is actively working with them to resolve the issue as quickly as possible.

We apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Sep 02, 2026 - 14:31 EDT
This incident affected: Socure ID+ Platform (eCBSV) and RiskOS Platform (eCBSV).