Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 24, 2026 - 21:00 EST
Update
During 9:00 PM (ET) Saturday, 01/24/2026 to 8:00AM (ET) Sunday, 01/25/2026, SSA will be utilizing a portion of the standard maintenance window to complete multiple activities and anticipate an outage for the eCBSV service during this timeframe.
Posted Jan 23, 2026 - 17:42 EST
Update
During 9:00 PM (ET) Saturday, 01/24/2026 to 8:00AM (ET) Sunday, 01/25/2026, SSA will be utilizing a portion of the standard maintenance window to complete multiple activities and anticipate an outage for the eCBSV service during this timeframe.
Posted Jan 23, 2026 - 17:41 EST
Update
During 9:00 PM (ET) Saturday, 01/24/2026 to 8:00AM (ET) Sunday, 01/25/2026, SSA will be utilizing a portion of the standard maintenance window to complete multiple activities and anticipate an outage for the eCBSV service during this timeframe.
Posted Jan 23, 2026 - 17:41 EST
Scheduled
During 9:00 PM (ET) Saturday, 01/24/2026 to 8:00AM (ET) Sunday, 01/25/2026, SSA will be utilizing a portion of the standard maintenance window to complete multiple activities and anticipate an outage for the eCBSV service during this timeframe.
Posted Jan 20, 2026 - 15:38 EST
This scheduled maintenance affected: Socure ID+ Platform (eCBSV).