[SEV 3] 5xx Errors Across Multiple Modules

Incident Report for Socure

Resolved

Socure services have now fully recovered and are operating normally. Our engineering and operations teams will continue to work to conduct a comprehensive root cause analysis (RCA) of the incident. We will share the RCA publicly within the next few days once this review is complete.
Posted Jun 26, 2026 - 16:26 EDT

Investigating

We are currently experiencing 5xx errors affecting multiple modules. Our team is actively investigating the issue and will provide updates as more information becomes available.
Posted Jun 26, 2026 - 16:06 EDT
This incident affected: Socure ID+ Platform (Sigma Identity Fraud, Sigma Synthetic Fraud, Predictive DocV, KYC, Email RiskScore, Address RiskScore, Account Intelligence, Phone RiskScore, Sigma Device, Alert List, Decision, eCBSV, Graph Intelligence, Negative Positive List, Sigma First-Party Fraud, Prefill, International Verify (eKYC), International Phone RiskScore, International Prefill, OTP, Silent Network Authentication (SNA)).